OAuth secret expressions fail to resolve during authentication after 4.20.0 upgrade

Incident Report for Cribl

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 12:41 PDT

Update

Mitigated: We have identified the issue affecting OAuth secret expressions following the 4.20.0 upgrade and published a Known Issue with a workaround. Customers experiencing authentication failures can follow the documented workaround.

Known Issue can be found here: https://docs.cribl.io/results/?searchOption=known-issues&tickets=CRIBL-45304
Posted Sep 16, 2026 - 11:23 PDT

Monitoring

We have published a known issue with a workaround for this issue. See https://docs.cribl.io/results/?searchOption=known-issues&tickets=CRIBL-45304
Posted Sep 16, 2026 - 10:57 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 16, 2026 - 10:44 PDT

Update

Update:
We are continuing our investigation regarding this issue.
Posted Sep 16, 2026 - 09:34 PDT

Update

Investigating: We are continuing to investigate an issue that may prevent OAuth secret expressions on Microsoft Sentinel destinations from resolving during authentication following the 4.20.0 upgrade.
Posted Sep 16, 2026 - 08:33 PDT

Investigating

We are currently investigating this issue.
Posted Sep 16, 2026 - 07:52 PDT